No SMB if boot with USB key.

Ideas and dreaming will go this forum
Post Reply

miazza
SamyGO Project Donor
Posts: 743
Joined: Wed Apr 03, 2013 6:10 pm

No SMB if boot with USB key.

Post by miazza »

Yesterday i realised that SMB was not anymore mounting.
After a few try and reinstall I found that the issue is that when I boot with USB key inserted I have no SMB.

Still trying to debug it.

miazza
AVOID TO PUBLISH AND DISCLOSE SAMYGO PROJECTS ON OTHER FORUM.

User avatar
mmhorda
SamyGO Project Donor
Posts: 152
Joined: Tue Jan 25, 2011 11:23 am

Re: No SMB if boot with USB key.

Post by mmhorda »

miazza wrote:Yesterday i realised that SMB was not anymore mounting.
After a few try and reinstall I found that the issue is that when I boot with USB key inserted I have no SMB.

Still trying to debug it.

miazza
Not only samba.
NFS doesn't work either.
It seems like vusb has a bug. It basically mounts virtual drive to a wrong location when you boot TV with plugged USB.
TV: LE40C750 - T-VALDEUC 3011.0
TV: UE40D6100 - T-GAS6DEUC 1026.0
TV: UE50ES6300 - T-MST10PDEUC 1042.0
NAS: MyBookLive 3Tb - Core F/W 02.43.03-022

zoelechat
Official SamyGO Developer
Posts: 8445
Joined: Fri Apr 12, 2013 7:32 pm
Location: France

Re: No SMB if boot with USB key.

Post by zoelechat »

I've got 2 USB storage devices (a key for PVR/timeshift and a drive for movies) plugged every boot time and smb is working well.

Virtual USB just disappear if I plug or unplug one of them when TV is powered on but is back on next reboot...
I do NOT receive any PM. Please use forum.

miazza
SamyGO Project Donor
Posts: 743
Joined: Wed Apr 03, 2013 6:10 pm

Re: No SMB if boot with USB key.

Post by miazza »

zoelechat wrote:I've got 2 USB storage devices (a key for PVR/timeshift and a drive for movies) plugged every boot time and smb is working well.

Virtual USB just disappear if I plug or unplug one of them when TV is powered on but is back on next reboot...
Quite interesting. You are facing exactly the opposit behaviour.
Did you install samygo with USB storage devices plugged ?

May be it si just the mounting sequence that makes the difference.
AVOID TO PUBLISH AND DISCLOSE SAMYGO PROJECTS ON OTHER FORUM.

User avatar
mmhorda
SamyGO Project Donor
Posts: 152
Joined: Tue Jan 25, 2011 11:23 am

Re: No SMB if boot with USB key.

Post by mmhorda »

zoelechat wrote:I've got 2 USB storage devices (a key for PVR/timeshift and a drive for movies) plugged every boot time and smb is working well.

Virtual USB just disappear if I plug or unplug one of them when TV is powered on but is back on next reboot...
Could you please paste here your vusb.init ? the one you use for PVR/timeshift.
It is not working for me if I have an USB drive in during boot.
Could you please also tell us what kind of hack you are using?
TV: LE40C750 - T-VALDEUC 3011.0
TV: UE40D6100 - T-GAS6DEUC 1026.0
TV: UE50ES6300 - T-MST10PDEUC 1042.0
NAS: MyBookLive 3Tb - Core F/W 02.43.03-022

User avatar
juusso
SamyGO Moderator
Posts: 10125
Joined: Sun Mar 07, 2010 6:20 pm

Re: No SMB if boot with USB key.

Post by juusso »

Looking forward to get solution for your probl guys. :|
LE40B653T5W,UE40D6750,UE65Q8C
Have questions? Read SamyGO Wiki, Search on forum first!
FFB (v0.8), FFB for CI+ . Get root on: C series, D series, E series, F series, H series. rooting K series, exeDSP/exeTV patches[C/D/E/F/H]

DO NOT EVER INSTALL FIRMWARE UPGRADE

User avatar
mmhorda
SamyGO Project Donor
Posts: 152
Joined: Tue Jan 25, 2011 11:23 am

Re: No SMB if boot with USB key.

Post by mmhorda »

miazza wrote:Yesterday i realised that SMB was not anymore mounting.
After a few try and reinstall I found that the issue is that when I boot with USB key inserted I have no SMB.

Still trying to debug it.

miazza
Hi,
I think i found a solution.
I have reset SmartHub to its defaults, re-rooted TV and it seems to be working now.
TV: LE40C750 - T-VALDEUC 3011.0
TV: UE40D6100 - T-GAS6DEUC 1026.0
TV: UE50ES6300 - T-MST10PDEUC 1042.0
NAS: MyBookLive 3Tb - Core F/W 02.43.03-022

zoelechat
Official SamyGO Developer
Posts: 8445
Joined: Fri Apr 12, 2013 7:32 pm
Location: France

Re: No SMB if boot with USB key.

Post by zoelechat »

mmhorda wrote:Could you please paste here your vusb.init ? the one you use for PVR/timeshift.
It is not working for me if I have an USB drive in during boot.
Could you please also tell us what kind of hack you are using?
I'm just using default unmodified vusb.init and TV's basic PVR functionality to record on physical USB. :)

I ever used only the first working rooting method, installing Test2 widget under develop account and SamyGo by ftp.
I do NOT receive any PM. Please use forum.

miazza
SamyGO Project Donor
Posts: 743
Joined: Wed Apr 03, 2013 6:10 pm

Re: No SMB if boot with USB key.

Post by miazza »

juuso wrote:Looking forward to get solution for your probl guys. :|
Any news on this juuso ?
AVOID TO PUBLISH AND DISCLOSE SAMYGO PROJECTS ON OTHER FORUM.

miazza
SamyGO Project Donor
Posts: 743
Joined: Wed Apr 03, 2013 6:10 pm

Re: No SMB if boot with USB key.

Post by miazza »

I found that the USB HD is mounted as sda1 and the samba is therefore mounted in sdb while still serching in sda.
I have forced the mounting on sdb and smb is there again ;)
AVOID TO PUBLISH AND DISCLOSE SAMYGO PROJECTS ON OTHER FORUM.

Post Reply

Return to “[E] Brainstorm”