samyext4.img corrupts over time. Automation of e2fsck possible?

Here for general support for F series TVs, request and problem solve area.
Post Reply

SamyGO Project Donor
Posts: 50
Joined: Wed Jan 02, 2013 10:46 pm

samyext4.img corrupts over time. Automation of e2fsck possible?

Post by aimaim »

Hi everybody,

I've always had the problem of samyext4.img somehow breaking. Then the tv would crash during startup until I would replace samyext4.img with a backed up version.
I had the notion, that it might just fill up. So I automated log deletion, disabled oscam logging and modified /mnt/etc/init.d/01_01_catch_crap.init according to viewtopic.php?t=10705 .
But the problem would still occur. So I monitored the "free space" in samyext4.img using 7zip and found out that indeed the free space was decreasing over time, i.e. the image was filling up.
So to increase the intervals in which I had to replace samyext4.img, I figured I'd just enlarge the image. I tried this using resize2fs on the unmounted image (in a linux vm).
"resize2fs -p samyext4.img 3G"

resize2fs however required me to use e2fsck first.
"e2fsck -f samyext4.img"

This then unearthed lots of messages about file system errors, that it offered to fix:
"deleted inode xxx has zero dtime"

After fixing these errors there was a hell of a lot more free space on the image than before, even without increasing its size to 3 GB, which I subsequently did anyway.

So now I got a 3 GB samyext4.img as a workaround. I'm hoping, that this will suffice for some months (years?) of collecting fs errors without filling all the way up.

A nicer solution would be:

a) to figure out where these errors come from (don't blame the thumb-drive, I've tried several). The tv does crash once in a while (meaning it reboots without being told to). Don't know if that could be a cause.


b) to somehow automate this repair-process. Unfortunately e2fsck should not be used on mounted images. So it's not as easy as creating an init-script, that does "e2fsck -p /dtv/usb/sda1/SamyGO_data/samyext4.img".

Any input on finding something better than my current workaround is appreciated!

Thanks in advance.

PS: Do you think I'm in the right category? It might not be specific to the F-Series?

Post Reply

Return to “[F] Support”