Samsung Accidental MICOM Upgrade

Information, questions and any other thing related with A series.

Posts: 1
Joined: Tue Dec 22, 2020 12:31 am

Re: Samsung Accidental MICOM Upgrade

Post by Toadie »

Many thanks to all the contributors of this thread and especially to AlHard
and the russian hackers who demystified the Weltrend Micoms and gave us tools to
debrick the "Micom upgraded" TV sets.

Some hints about debricking my UE55ES6530SXZG (maybe I'm repeating information
from older posts -- sorry for that):

1. Cause of my bricked TV was the infamous "Micom upgrade" feature in the
maintenance menus (If only i had read SamyGO prior to that).

2. Providing a Firmware Update on USB-Stick didn't work.
Bricking the Micom chip normally means, no power to the Main CPU, so you
don't have the chance to execute a firmware update (but nevertheless there
are reports, that this has worked for some sets; so just try it).

By the way: You can start the main CPU and the display by pulling out the
SW_PWR_OUT Line and the SW_INVERTER Line out of the power connector (pinout is
printed on the circuit board). You can then use an external
keyboard to start the firmware update. In my case, that didn't restore the
Micom firmware.

3. The Mainboard BN-41018071 in my TV set uses a 48pin WT61P805. I used
the SCL-Line on pin 23 and SDA on pin 22. You can reach these pins via
a connector nearby (CN1204_DB on my board). The BN-4101807 doesn't have a
VGA-connector, so you have to connect to CN1204_DB or similar pins. I
don't believe, that you can use the hdmi I2C on this mainboard.
Maybe the other I2C interfaces of the chip can be used as well, but I haven't tested.

4. Use Inteface type "VCT-Jig" with the described PEGAS_2 Interface in Postal 2.
There's also a selection "74HC05" for a corresponding interface that is slightly
easier to build. You can use simple NPN-Transistors, if you don't have the HC
Chips at hand, as the interfaces are Open Collector / Open Drain.

5. Flashing the WT61P805 Micom in place in the TV set didn't work for me. Postal 2
showed a "I2C bus is busy". Seemed there was something pulling SDA and SCL down after
a short period of time.
I had to dismount the mainboard and provide 5V on the A5.3V line (s. printing on mainboard).
Other connections in addition to GND, SCL and SDA hadn't been necessary.
Just providing 3.3V to the chip didn't work for me, as the reset-chip pulls NRST to GND when
5V isn't provided.

6. Configuration in Postal 2: Philipps, VCT-Jig, Normal speed, Weltrend.
Before entering ISP mode I pressed "Status", until the message says "WT61P805".
This step is maybe unnecessary.

7. After Entering ISP mode, Postal 2 shows a buffer size of 49152. There seems to be
a fault in Postal 2 (or is it user too stupid?), because if you use this buffersize,
it only reads about 18192 bytes and complains later in the verification stage;
the backup files are also too small.
Setting a size of 53248 by pressing the "Status" Button worked for me.

8. You can extract the Micom Bin-File from the official Firmware provided by Samsung.
The extraction process is described in the SamyGo wiki + see post from Brian1969.
The bin-file is located in the exe.img in the root folder (SubMicomEU.bin in my case).

My UE55ES6530SXZG is now working again; sadly it still shows the one malfunctioning
line that was the root cause of my adventures into the samsung maintenance menu. Any ideas,
if this can be repaired without changing the whole panel?
You do not have the required permissions to view the files attached to this post.

Posts: 4
Joined: Sun Apr 25, 2021 4:40 am

Re: Samsung Accidental MICOM Upgrade

Post by samsungmu6300 »

Hello everyone, can you guys help me with my problem . My tv UN50MU6300
Samsung smart tv , i mess something in hide menu and tv now is black screen . No hide menu ni nothing.. black screen that's it . Jump scl + vcc didt help
I tried to many times but with no luck.
Eproom Windbod . I don't know what else i should do to bring in live the tv ..
Please someone help with this situation.
Why i mess up with hide menu ?
I couldn't reset the tv factory , i couldn't go through term and Conditions .
Every time agree term and Conditions says ,, wait or no answer by the server .
I have good internet connection 30 ping 100mb speed ..
So i decided to reet but no luck.. after I decided to go in service menu , what I did i don't remember, what I see now is black screen . No sound nothing I see red light on infrared I can feel the tv turn on or off with remote..
If I have to jump 2 lines I did SCL+VCC I believe I did well . But no luck. If I missed anything please help me to bring in life my tv .
I cant put any photo right now , the tv is been close with all screws.
There is online mainboard you can take a look . But I believe you guys know what I'm talking about ..
I can reprogram i can do it maybe , but I have no windows xp or programator.. I didt do this never . I'm good to sold wires, I'm good to change iphone batteries. I'm good little bit in electronics stuff.. so please be patient and explain what else I can do .Thanks a lot everyone

Samsung smart tv 2017 UN50MU6300...

Post Reply

Return to “A Series”