EX-Link UART Control

General forum talking area for J series TVs.
Post Reply

Imaginous
Posts: 1
Joined: Fri Feb 05, 2016 7:44 am

EX-Link UART Control

Post by Imaginous » Fri Feb 05, 2016 8:01 am

Hi,

I couldn't find the answer on the internet to control the J series (at least my 55JS8000L) via LAN or UART.
According to the SamyGO wiki page there is no communication in UART mode.

After some hours of trying and testing I managed to get it to work. You can use the HEX codes found on the net to control the TV even turning it ON.
I'm at work now so I only can type a brief description:

Enter the Service Menu (how is explaned in a threat on this forum) -> Options -> Sub Options
Set: RS232 Jack - UART
Set: Enable UART - ON
Leave the menu's and power off the TV with the remote.

Power on the TV in normal mode and TURN OFF Anynet+ (HDMI-CEC). As long as this is on you won't be able to control the TV.
Turn off the TV once again and turn it back on again.

Now you can connect to the TV with an EX-Link Cable (3.5MM Jack to DB9 - RS232 level). You can use a USB to Serial converter.

Set the com port to:
9600 baud (115200 is for serial console debugging only)
8 data bits
1 stop bit
Parity None
Handshake None

Now you can control your TV like described on this page:
http://forum.team-mediaportal.com/threa ... elp.91088/


This is my first post on this forum, so I hope I use the correct forum thread.

TerabitDJA
Posts: 1
Joined: Tue Mar 08, 2016 7:20 pm

Re: EX-Link UART Control

Post by TerabitDJA » Tue Mar 08, 2016 7:26 pm

Thanks for the help Imaginous. I've been working on this off and on for awhile and I was about to give up.

I have a 40JU7500FXZA and using your advice below, I was able to get it to respond to one command, Power On (which is actually the Power Toggle code). Have you (or anyone else reading this) had any luck with a J series and any other code?

taudris
Posts: 1
Joined: Sun Apr 10, 2016 7:18 am

Re: EX-Link UART Control

Post by taudris » Sun Apr 10, 2016 7:30 am

I found a spreadsheet here with tons of codes: http://www.remotecentral.com/cgi-bin/fo ... gi?1270285

The ones I've tried are power on/off, volume, and brightness. They all worked without a hitch. I don't know about any of the others.

The one thing I can't figure out is if there's a way to disable the fullscreen OSD background that fades everything when setting volume and brightness via the EX-Link port. I'm using my TV as a PC monitor, so I want these things to be as invisible as possible except for the result.

LuisNill
Posts: 1
Joined: Thu Oct 17, 2019 6:33 pm

Re: EX-Link UART Control

Post by LuisNill » Thu Oct 17, 2019 7:01 pm

Hi...I do have all if not most of those service mode options. I don't recall where I left it but in every mode I tried the TV would not turn off when sent the off command. This could be that my connection on the 1/8" jack is faulty since I can barely see crap that small, I'll have to verify I guess by shorting tip to ring, maybe base and ring are swapped but I don't think I'd rx anything which I did, all that gobble-di-goop that comes in when powered on when using Samsung's IR remote.

Post Reply

Return to “[J] General”