Samsung QM49R reset EEPROM

General forum talking area for R/QR series TVs.
Post Reply

suiramix
Posts: 4
Joined: Sun May 16, 2021 3:47 am

Samsung QM49R reset EEPROM

Post by suiramix »

Hi there,
Got this non-working Samsung model QM49R, like new (Aug 2019), plugged-in, after 5 sec power up (without pressing the power button) with backlight on but no start up sound, no image.
Hard to be power off by the switch or remote.
Pressed on remote control "EXIT" then "Left" and "Enter"...the front red led was blinking!
Restarted and I heard loud and clear ”Please select your language” message… but no image on the screen !!!
Next, I want to Reset EEPROM that means to short the VCC and SDA for 20sec.
On the mainboard (BN94-14556B) there are two chips IC1603_UT (W25Q80D) and IC1604 (W25Q40CL)...
I assume the first one is communicating on I2C protocol even is a serial flash SPI chip.
Please confirm if this is the right one !
You do not have the required permissions to view the files attached to this post.

suiramix
Posts: 4
Joined: Sun May 16, 2021 3:47 am

Re: Samsung QM49R reset EEPROM

Post by suiramix »

Looking closer, I did find the 3rd chip on this main board, this time IC801, label SUBMICOM, M24512...can I do a reset on this on ? thanks!
You do not have the required permissions to view the files attached to this post.

User avatar
notengo13
SamyGO Project Donor
Posts: 567
Joined: Mon Nov 30, 2015 12:31 pm
Location: Slovakia

Re: Samsung QM49R reset EEPROM

Post by notengo13 »

Check on spare pages for eeprom
W25Q40CLSSIP
Before do anything check twice that is the correct eeprom.
UE48H6640 T-MST14DEUC 2781.0 root latestH --> 2130.0 skypeRoot-->0000-->2115.3 "Skype refueled" Root

suiramix
Posts: 4
Joined: Sun May 16, 2021 3:47 am

Re: Samsung QM49R reset EEPROM

Post by suiramix »

Hi Notengo,... thanks for the info, I will try to get that chip!

suiramix
Posts: 4
Joined: Sun May 16, 2021 3:47 am

Re: Samsung QM49R reset EEPROM

Post by suiramix »

Hi there,
I did find a mainboard spare part, exact part number as original, as per e-bay seller: brand new/unused ...receive it, replaced the old one, double check the connections, plug-in the AC power cord and... same issue: tv starts by itself, the display backlight is on with no image and same voice message to do the initial set-up !!
According with some similar service manual, after mainboard was replaced "please change the factory option as well"...but is nothing to see on the screen!
Ultimately, I tried to reset the EEPROM chip (IC801, ST24512) ... following the standard procedure, unplug the power cord, short SDA and VCC, plug in the AC cord, wait 30-45sec...during this time the screen and backlight are NOT turning on, remove the short, the tv is turning on by itself with same voice but no image !!! Should I wait more than 45 sec? Could be the display defective or different P/N ? Any ideas ? Can I connect an external monitor to this tv set (reading some EU models have this option to SCART connector...)

Post Reply

Return to “[R/QR] General”